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Introduction
Congratulations! You’ve just acquired the newest and most useful tool in audio
production since the invention of the manual mix console.

The Voyager Sound GraphiMix system goes beyond mere manipulation of controls and
empowers the audio engineer by providing a unique method to visualize and control the
sound. This provides an alternative to ‘glass console’ controls and provides a ‘Sound
stage view” to better perceive and control multi-channel mixes. Easy to use templates are
supplied to provide a ‘quick start’ graphic mix surface which can be modified and
customized to almost any degree.

GraphiMix includes a graphic tool kit which gives the engineer the ability to create
custom graphic mix surfaces to drive any MIDI-compatible hardware or software. The
tool kit includes conventional as well as unique and innovative graphic controls which
give the engineer an unprecedented level of control.

GraphiMix incorporates a very flexible system for data input and output. It can be used
with almost any MIDI-compatible hardware ranging from PC sound cards to professional
digital mix hardware and can be used with MIDI sequencers.

To use GraphiMix, you must first download and install it. If this hasn’t already been
done, see Installation and Licensing for a Web Download., page 90.
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For a quick demo and tutorial that only requires a PC sound card with MIDI synthesizer
capabilities (which is most of them), click on the RunDemo icon in the GraphiMix
Program Start Menu.

With GraphiMix running and attached to a supported target Mix Console, most controls
available including effects, can be manipulated by using GraphiMix Mix Icons and Mix
Forms, and any movement of controls on the Mix Console will be reflected in the change
of position of the appropriate GraphiMix Mix Icons. For a complete description of the
use of the keyboard and mouse with GraphiMix, see Using the Keyboard and the Mouse,
page 57.

Additionally, users who have hardware mix surfaces or mix consoles can easily integrate
these with GraphiMix and can easily link these together to create custom hardware Mix
Surfaces for consoles and applications.

System Requirements
A computer with a 500 Mhz or faster Pentium-class processor with system memory of
256 Megabytes minimum, is recommended. Windows™ 98, NT, ME, 2000, and XP are
the supported operating systems.

Memory, resource usage, and responsiveness is a strong function of the number of
graphic controls and Mix Forms that are on screen and accessible at any one time. To
reduce the load on the system, the user can segregate less often used controls into a
separate Scene or State which reduces resource requirements without impacting the
utility of the session. Higher speed machines and more memory will permit faster system
response times.

Microsoft operating systems currently have a serious limitation on the total number of
MIDI devices (to 10). Only Windows™ ME and XP (currently) support more than this,
so this may be a consideration if the user needs more than 10 devices. If you do attempt
to install more than 10 MIDI devices on other Windows systems, MIDI may appear to
work but will cause your system to be unstable.  Do not do this!

To run the demonstrations provided with the release, the computer must be equipped with
at least a sound card and stereo speakers. To work with external MIDI mixers and other
hardware, the computer should be equipped with at least one external MIDI port
(UART).

GraphiMix Overview
The future of sound processing and mixing is in the digital box. Advanced performance is
available using DSP technology at a very low price. The challenge is delivering this
capability to the audio engineer.
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The standard mix console has been around in its basic form since the 1930’s. At that
time, the control layout was dictated by the necessity of physically wiring the signals
from control to control. The location of each control was determined by the electronic
necessity of switching that signal there, and fading this signal here, between these two
other signals over there, etc.

This method of control has persisted to this day. Until recently, the mix hardware still
retained the necessity of routing and controlling physical audio signals. Although the size
of the electronics got smaller and the number of features increased, this only resulted in
more controls in as small a space as possible.

With the new DSP technology, the audio control layout and design is now entirely freed
from any need to route the audio signal, yet the method of control invented years ago,
still persists.

Designing Audio vs. Just Moving Controls
What is not accounted for was that a human engineer can only adjust 2 or 3 controls at a
time. The need to simultaneously adjust a couple of channel levels, pan positions, reverb
and effects parameters to effect a simple dynamic stereo mix could require two or more
engineers.

As hardware capabilities multiplied, the audio mix engineer’s ability to control became
more difficult. An increasingly sophisticated audience demanded better audio quality and
more spectacular effects. Film, album production and multimedia all required more
control than a single engineer could easily provide in real time.
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Automated systems allow a sophisticated mix to be built, often a single ‘control layer’ at
a time, but even relatively simple mixes in surround sound films can take hours to
complete.

With the recent generation of audio mixer/effects-in-a-digital-box such as the Yamaha™
01V™, 03D™, or 02R™ powerful capabilities are brought within the price range of the
Music Instrument (MI) market. The audio quality is good enough to be useable by major
studios. However, to keep the price low, these systems offer much less than full control
of every feature separately. They have ‘assignable’ controls which must individually be
attached to the audio parameter being controlled.

This recognizes that a single engineer can only adjust a few controls at a time, but does
not address that engineer’s need to adjust many more parameters at the same time and in
a coordinated fashion in order to produce high-quality, sophisticated sound mixes.

The Visual Audio Environment
Voyager Sound has developed and patented an entirely new and revolutionary approach
to this problem. This intuitive, graphical system enables the audio engineer to visually
perceive the control of mix and sound processing as input channel Mix Icons placed in
output channel ‘space’.

Since a human naturally processes visual information in terms of spatial relationships and
appearances, this can be easily mapped to sound relationships and processing parameters.
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Basic Mix Form

The appearance of a Mix Icon can represent a source of sound. For example, an icon with
the word SAX or a picture of a saxophone represents the sax channel. The color of that
icon, or the position of a fader on a complex Mix Icon, could represent the tone control
setting or filtering for that channel. The angular placement on a stereo screen could
determine the setting of the pan position control. The icon’s distance from a mix ‘origin’
could determine the overall channel level. And so on.
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3 Band Parametric Equalizer

This concept can also be applied to the control of effects, where the output channel
‘space’ can be effects parameters. For example, the icon’s distance from the origin can
represent the amount or depth of reverb, or the amount of audio compression applied, or
any other set of audio parameters. This mapping can be applied to any icon, so that the
movement of a single Mix Icon represents the coordinated adjustment of many console
‘knobs’ and ‘faders’.

This type of control is unavailable on any console available today and would require
multiple engineers acting in a rehearsed and coordinated fashion.
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Stereo Mix Form Screen

 

This representation is much more natural and easy to perceive and manipulate than an
arbitrary array of faders, knobs and switches.

One or more channel icons can be placed on this screen, which could represent the full
range of control of a stereo fader and pan-pot available on a normal console. Every
position of the channel icon represents a unique setting for these two controls for that
channel.

GraphiMix can also simulate the operation of a fader and pan-pot with two level controls,
each from an input to a separate output bus. GraphiMix can also simulate faders and
surround pan-pots using arrays of virtually any number of level controls and output
channels

Multi-channel and surround sound will soon be the rule rather than the exception.
Simulating realistic sounding effects and providing interactive control over 6 or 8
surround channels is impossible to do any other way. Single point ‘physical fader’ control
is no longer sufficient. Conventional control of these channels would require a ‘joystick’
with four or more physically linked fader elements at each position. This quickly
becomes expensive and impractical.
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Surround Sound Mix Form

 

This shows the Voyager Sound GraphiMix Surround Mix Form. Each Mix Icon placed
on this Mix Form causes 4 or more channels to be automatically set appropriately to
create a multi-channel mix. Additionally, the linking characteristic can be changed and
modified in software to provide the ultimate in surround sound mix flexibility.

The Voyager Sound GraphiMix system makes it possible to really control the capability
in the box. It can support large channel counts and still provide powerful creative and
interactive control for the engineer. In film and multimedia mixing, the system is an
enabling technology which will save time and money while simultaneously enabling
much more sophisticated mix capabilities.
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Voyager Sound has the only practical way to meet these requirements. Voyager Sound
has a U.S. Device Patent (#5,212,733) and European Patent (#0 517 848), which grant
Voyager Sound Inc. exclusive rights to this method of control.

GraphiMix Input and Output

The GraphiMix system allows coordinated operation of multiple controls on multiple
hardware units with the movement of a single icon.

GraphiMix supports a complex interconnection of multiple hardware units and types.
Surround Sound and multi-channel configurations can be easily created out of cascaded
hardware units such as the Yamaha ProMix™ series of digital mixers as well as consoles
from Tascam, Soundcraft, Behringer, and others. Additional mix hardware of any type
integrates easily into the system.

Multiple MIDI ports are easily supported to improve performance in large systems. The
system can be easily adapted in the future for other protocols and mix control hardware.

What this all means is that audio hardware can be easily connected to a GraphiMix Mix
Icon and manipulated in a way that is visually intuitive to the sound engineer. If an
arbitrary control should work in an up-and-down manner, or a side-to-side manner, or in
an angular manner, in the opinion of the individual sound engineer, it can be made to
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work that way. GraphiMix can make the same hardware appear differently to the sound
engineer for every session or every production. It can also make each session appear
identical to the sound engineer even though the hardware may be completely different. It
can be easily customized and allows creative freedom in the way that any particular mix
is perceived and manipulated by the sound professional.
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Quick Topics
Here are some topics that might be of specific interest to the audio engineer.  For more
complete treatment of any of these topics, please see the GraphiMix Reference Manual.

Selecting Icon Images
To change the image displayed for a particular Mix Icon,
1. Bring up the context menu by right-clicking on the Mix Icon.
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2. Click “Select Image…” on this menu to bring up the Mix Icon Images dialog.

3. Now, select the new image by left-clicking on it. Use the scroll bar at the right to
bring the desired icon image into view. Click OK when selected.

Changing the Track Number of a Mix Icon.
The user may want to change the actual channel of a particular Mix Icon and its attached
Mix Forms. For example, the engineer may want to use just a few tracks but with track
numbers that are greater than 16. To do this easily, we use GraphiMix’ Find and Replace
feature.

1. First, set GraphiMix to ‘Build’ mode  by clicking on the Run/Build Mode switch
on the standard toolbar.

Standard Toolbar

2. Now select the Mix Icon (Track 1 in this example) that you want to change the track
number for. Right-click on this icon and ‘Show All’ of the attached Mix Forms by
checking them in the context menu.
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3. Now, you probably should change the image to the new track number. In the Mix
Icon’s context menu, click on ‘Select Image…’ and choose the button image that
matches the new track number.

4. Again, in the Mix Icon’s context menu, select “Find And Replace…”. The following
dialog will come up.
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5. This may look a little daunting, but it’s not that hard. In the ‘Search Criteria’ area,
check the Vsl File field and select Graphison.vsl. This ‘finds’ every control that is a
SONAR control. The SONAR midi driver file, Graphison.vsl, uses the convention
that puts the actual channel number in the ‘Program’ field of the control. VSL driver
files for other consoles may use other conventions such as the ‘Parameter field’ or the
‘Component’ name. To figure this out, look at the controls tab of the Mix Icon
Properties dialog. The control description and control setup for each individual
hardware device should indicate how to change the channel number.

6. In the ‘Change to’ field, check the Program checkbox and put the new channel
number in the Program field (shown here as 25). All other unchecked entries are
‘don’t cares’ and are ignored.

7. Set the scope field (bottom left) to ‘Search only This Mix Icon’. This should be set by
default.

8. Now click ‘Search and Replace’. The following dialog will come up.
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All 6 attached controls now are set to channel 25.

9. click ‘Done’.

10. Click the ‘Bring to Front’ button  on the standard toolbar.

11. Now, right-click on the Linked Mix Form “Channel1 Controls” (in this example).
Click on a part that is not an icon, i.e. on the background.  Select “Find And Replace”
again.
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12. The Find and Replace dialog will already be set from the first find and replace. Set
the Scope field to “Search All Icons on this Mix Form” which should be set by
default,

13. and click on “Search and Replace”.

14. Now the following dialog should come up. Click OK and then click on “Done” in the
Find and Replace Dialog.

15. Now this Mix Icon and its linked Controls Mix Form are set to Channel 25. Change
the name of the Control Mix Form by selecting “Properties” on the Mix Form context
menu

16. and typing in the new name, i.e. “Channel25 – Controls”. Click OK.
17. Hide the Controls Mix Form by selecting “Hide Mix Form” on the Mix Form context

menu.
18. Repeat steps 10-17 for each linked Mix Form (if any).
19. Return GraphiMix to Run Mode  .

Adding a Track
1. First, set GraphiMix to ‘Build’ mode  by clicking on the Run/Build Mode

switch on the standard toolbar.

Standard Toolbar

2. Now select a Mix Icon that represents a channel that is similar to the new one to
add (for example, MIDI or Wave).

3. Show all of its linked Mix Forms by using the Mix Icon’s context menu (right-
click).



21

4. On the GraphiMix Window Menu, click on “Tile”. This forces the linked Mix
Form(s) to ‘share’ the GraphiMix window and remain visible.
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5. Now, make sure that the Mix Icon to be ‘cloned’ is selected with a red box around
it (left click on Mix Icon). The title bar of the selected Mix Icon’s Mix Form
should be highlighted in blue.

6. Click on the Edit menu and select “Copy Mix Icon”. This copies the Mix Icon
into the Windows Clipboard buffer. Typing a <control-C> also performs this
command.
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7. Now, click on the Edit menu again and select “Paste Mix Icon” (or type <control-
V). An identical copy will appear on the same Mix Form.

Now there will be two Mix Icons with the same image and all the same properties. The
pasted Mix Icon will show up on top of the original icon. Drag it to a different position.

8. Right-click on the new icon and bring up the context menu. First, change the
image by clicking on “Select Image…”.

9. Select the new image and click OK.
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10. Right-click on the new icon and bring up the context menu again. Now select
“Deassign Linked Form”. The cursor will change to a Deassign Linked Form
cursor.

11. Click on the original linked Mix Form.

12. Repeat steps 10-11 for all linked Mix Forms for this icon (if any).

13. Now click on the original linked Mix Form (which is still linked to the original
Mix Icon).

14. From the Edit menu, select “Copy Mix Form”.

15. Again, from the Edit menu, select “Paste Mix Form”. An identical copy of the
original Linked Mix Form should appear. <Control-C> and <Control-V> will
work as long as no Mix Icon is selected (surrounded by a red box) on this Mix
Form.
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16. ‘Put away’ the original Mix Form by deselecting it from the original Mix Icon’s
context menu.
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The remaining linked Mix Form is the ‘new’ one.

17. Change the name of this new Mix Form by selecting “Properties” from the Mix
Form’s context menu (right-click) and typing in the new name. Click OK.

18. Now, link this Mix Form to the new icon by ‘pulling up’ the new Mix Icon’s
context menu and selecting “Assign Linked Form”. The cursor will change to the
“Assign Linked Form” cursor.

19. Click on the new linked Mix Form.
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The new icon’s context menu will now show the new linked Mix Form.

Finally, we need to change the channel parameters of the new Mix Icon and the new
linked Mix Form.

20. Again, in the Mix Icon’s context menu, select “Find And Replace…”. The
following dialog will come up.
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21. This may look a little daunting, but it’s not that hard. In the ‘Search Criteria’ area,
check the Vsl File field and select GraphiSon.vsl. This ‘finds’ every control that is
a SONAR control.

22. In the ‘Change to’ field, check the Program checkbox and put the new channel
number in the Program field (shown here as 25). All other unchecked entries are
‘don’t cares’ and are ignored.

23. Set the scope field (bottom left) to ‘Search only This Mix Icon’. This should be
set by default.

24. Now click ‘Search and Replace’ and then click ‘Done’. The following dialog will
come up.
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All 6 attached controls now are set to channel 25.

25. Now, right-click on the new Linked Mix Form “Channel25 Controls”.
26. Select “Find And Replace” again. The Find and Replace dialog will already be set

from the first find and replace.
27. Set the Scope field to “Search All Icons on this Mix Form” which should be set

by default, and click on “Search and Replace”. Now the following dialog should
come up.

28. Click OK and then click on “Done” in the Find and Replace Dialog.

29. Now this Mix Icon and its linked Controls Mix Form are set to Channel 25. Hide
the Controls Mix Form by selecting “Hide Mix Form” on the Mix Form context
menu.

30. Set the Run/Build mode switch back to Run mode .

Deleting a Track
1. First, set GraphiMix to ‘Build’ mode  by clicking on the Run/Build Mode

switch on the standard toolbar.

Standard Toolbar

2. Now, unhide all Linked Mix Forms by pulling up the context menu (right-click)
and selecting “Unhide all Linked Mix Forms”.

3. Delete each Mix Form by clicking on its Background and typing <Delete>.
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4. Finally, delete the Mix Icon by selecting it and then pressing the <Delete> key or
by clicking on the Edit Menu and selecting “Delete Mix Icon”.

5. Set the Run/Build mode switch back to Run mode .

Moving a Track
For each Mix Icon,
1. Select it by left-clicking on it..
2. Click on the Edit Menu and select “Cut Mix Icon” or type <Control-X>.
3. Now click on the destination Mix Form.
4. Click on the Edit Menu and select “Paste Mix Icon” or type <control-V>.

Adding a Mix Icon
To add a Mix Icon to a Mix Form,

1. Click on the ‘Insert’ menu and select ‘Insert New Mix Icon’. The mouse pointer
will change to an ‘Insert Mix Icon’ pointer.

2. Click on a Mix Form to insert a default Mix Icon on the selected form.
3. To change the image and icon type, <right-click> on the icon and click on ‘Select

Image…’.

4. Click on the new image and then click on the OK button.

Adding a Mix Form
To add a Mix Form to a session,



32

1. Click on the ‘Insert’ menu and select ‘Insert New Mix Form’. Alternatively, you
can use the ‘View’ menu to select ‘Mix Form Tool Bar’. Click on the middle
button to insert a new Mix Form.

2. To change the name and the appearance of a Mix Form, first set GraphiMix to

‘Build’ mode .
3. <Right-click> on the Mix Form background and select ‘Properties’.
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4. Type in the name and set the Mix Form geometry attribute.
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5. Click OK when done.
6. Set the Run/Build mode switch back to Run mode .

Creating a Sub Mix
A Sub Mix is essentially a separate Mix Form with related channel Mix Icons placed on
it. These channels may or may not be linked to ‘Master’ icons on the same or another
Mix Form.
To create a Sub Mix, add a new Mix Form and then ‘Cut and Paste’ Mix Icons from the
Main Stereo Mix Form to the new Mix Form.

If a lot of Mix Icons are to be moved to another Mix Form, it may be quicker to copy the
entire Mix Form and then delete the Mix Icons that don’t belong.

To create a sub-mix by copying a Mix Form,

1. First, put GraphiMix in ‘Build’ mode by depressing the Run/Build mode switch

 on the standard toolbar.
2. Then, select the Mix Form to be sub-divided by clicking on it.
3. Click on the Edit Menu and select “Copy Mix Form”.
4. Click on the Edit Menu again and select “Paste Mix Form”. Now there will be

two identical Mix Forms with complete sets of Mix Icons.
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5. Rename the new Mix Form by using the context menu and selecting “Properties”.
6. Type in a new name and click OK.
7. Now delete the Mix Icons that don’t belong in each Mix Form by <left-clicking.

on each one in turn and pressing the <delete> key.
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8. You may want to link this Mix Form to a particular Mix Icon on the Main Stereo
Mix Form. <Right-Click> to access the Mix Icon’s context menu and select
“Assign Linked Mix Form”. Click on the new Mix Form to link it to the selected
Mix Icon. Now, you can ‘Hide’ the Sub Mix and ‘Recall’ it from the selected Mix
Icon’s context menu.

9. Return GraphiMix to ‘Run’ mode .
10. Save the session.

Creating and/or customizing Icon Images
Icon images can be created and customized using the Edit/Create Mix Icon Images
selection on the GraphiMix Tools menu. Normal icons, both momentary and toggle
switch icons, drop-down index list icons, faders and knobs, can all be created, copied,
and modified here. The user can also import windows bitmap files (BMP’s) to use as icon
images. Each Mix Icon has 9 images states (3 sizes (times) normal, solo, mute) and all
can be custom-selected by the user. A switch Mix Icon has 18 states, (9 for On and 9 for
Off). Icons can be also created out of text with full choice of colors and fonts.
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Weecons can be added to visually add channel or track numbers, or microphone number,
or other distinguishing letters or numbers to the Mix Icons. To access “Weecons”, right-
click on the Mix Icon and select “Properties”. Then click on the “Weecons” tab at the top
of the dialog.
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The resulting Mix Icon image looks like this.
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Icons can also be used as labels on the Mix Form. These icons can be placed with the
‘Allow Left Click’ checkbox unchecked in the Mix Icon Properties dialog. You will also
want all context menu items to be removed. Uncheck all the ‘Show …’ checkboxes in
this dialog for this.

Mix Icons are files with the extension ‘VLB’ and are contained either in the VLB
subdirectory of GraphiMix (the ‘primary’ set) or one of any number of user created
subdirectories in this directory. To view these directories, select the View menu-View
Icon Windows … entry. This brings up a window of VLB directories. Highlight one or
more VLB directories in this window to see the icon windows that correspond.
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For more information on creating Icon Images, see the GraphiMix Help or the GraphiMix
Reference Manual.

Adding Equalization and Effects
As an example of adding Linked Mix Forms for controls such as equalization and effects,
we will load the ‘SONAR Audio and MIDI DEMO2’ project in the Cakewalk Sample
Content directory. This project uses the Cakewalk FXReverb in the Guitar Track channel
and we will add some controls for this unit on a new Mix Form linked to the Mix Icon on
track 3 (Guitar).
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By double-clicking on the ‘FxRev’ text, the following panel comes up.

1. To create a new Mix Form, select the View menu in GraphiMix and click on Mix
Form Tool Bar. A tool bar will appear at the upper right corner of GraphiMix.
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2. Click on the middle button. This will create a new Mix Form.
3. You can select the View menu again and unclick the Mix Form toolbar entry to

‘put it away’.

You can also use the Insert menu to Insert a New Mix Form instead of using the toolbar.
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4. Set GraphiMix to ‘Build’ mode  by clicking on the Run/Build Mode switch on
the standard toolbar.

Standard Toolbar

5. Now <right-click> on the new Mix Form and select Properties.
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6. Set the name of the new Mix Form and set its type to ‘Stereo Rectangular’. Click
OK
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7. Now, click on the View Menu and select “View Icon Windows…” .
8. Click on the Primary VLB window to get the primary icon selection window.
9. Now, select a Mix Icon (it can be changed later) and drag it to the new Mix Form.

10. <Right-click> on the new Mix Icon and select Properties.
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11. Type in the icon’s name.  Set the icon’s movement constraint to ‘ConstantX’ (up
and down only).

12. Now select the Controls tab.
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13. Click to add a control. Now fill in the name and select the VSL file to be
graphison.vsl. The component is ‘Eff_Track_FxReverb’ and the control is
‘WetDryMix’, select these from the drop down lists.

14. Set the Coordinate to be ‘Y’ (up and down) and, finally,
15. set the Program register number to 3 (since this reverb control is on track 3).
16. Click OK.
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If you bring up the SONAR FxReverb panel you should be able to see the control move
as you move the GraphiMix Mix Icon up and down. If you move the control on the
SONAR panel, the GraphiMix Mix Icon should respond in kind.

17. Now attach the new Mix Form to the Track 3 Mix Icon as a ‘Linked Mix Form’.
18. First, pull down the window menu and click ‘Tile’. This forces the new Mix Form

to remain visible.
19. <Right-click> on the track 3 Mix Icon (make sure GraphiMix is in ‘Build’ mode)

and
20. select ‘Assign Linked Form’. The cursor will turn to the ‘Assign Linked Form’

cursor.
21. Click on the new Mix Form.
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22. Now the Guitar track reverb form can be hidden. To hide it, <right-click> on the
Mix Form and select ‘Hide Mix Form’.  To recall it, <right-click> on the track 3
Mix Icon and select ‘Guitar Track Reverb’.

Note that now the new Mix Form appears on the Mix Icon’s context menu. Multiple
Linked Mix Forms can be linked to any Mix Icon.  More controls can be easily added to
the new Mix Form and calibration axes can be created and attached, dynamic displays
can be turned on and whatever else the user wants can be added.
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To add controls for the Aux bus effects, select the “Eff_Aux_ …” components. For the
virtual mains use “Eff_Main_ …” components. Be sure to set the Program register
according to the Aux bus number or Main bus number in those controls.

23. Return GraphiMix to ‘Run’ mode .
24. Save the session.

Adding a Switch
1. First, set GraphiMix to ‘Build’ mode  by clicking on the Run/Build Mode

switch on the standard toolbar.

Standard Toolbar

2. To add the FxReverb ‘bypass’ switch to the reverb Mix Icon we just added,
<right-click> on the new Mix Icon.

3. Select Properties, then select the Controls tab.
4. Now click on ‘Insert CTRL’. Fill it in as shown.
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5. Then add the ‘Off’ state control by clicking the ‘Insert CTRL’ button again.

6. Set the Coordinate to ‘SoloOff’.
7. Click OK and try it. <Shift-left click> on the Mix Icon to toggle its solo state.

Now, when the Mix Icon is in normal state, the reverb bypass switch is on, and
conversely, when the Mix Icon is in Solo state, the bypass switch is off. This is probably
exactly opposite to what is desired.
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8. To change this, <right-click> on the Mix Icon, and go to the Controls tab.

9. For both the BypassOn and BypassOff controls, invert the settings of the Min and
Max registers.

10. Now click OK and try again.
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Now, the switches display the correct states.
11. Return GraphiMix to ‘Run’ mode .
12. Save the session.

Adding A Control to a Mix Icon
You may want to add a control to a Mix Icon to automatically add effects which change
relative to the position of the icon. Using the Soundcraft 324 as an example, we will add
the effects ‘FXLevel’ control to the position of the guitar icon so that as the volume of
the channel is faded out, the sound becomes ‘wetter’ (more reverberant), and as the
channel volume is increased, the sound becomes ‘dryer’.

To do this,
1. First put GraphiMix into ‘Build’ mode.
2. Now, select the Mix Icon and <right-click> on it to bring up the context menu.
3. Select the ‘Properties’ entry.
4. Click on the ‘Controls’ tab.
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5. Now, click on the ‘Insert CTRL’ button. Enter the settings as shown. You will
have selected the ‘FXLevel’ control in the ‘FXUnit_1’ component. Make sure the
Data Type field is set to ‘Fader’ and the Coordinate set to ‘Radius’. This sets the
level control to be ‘wetter’ at the outer edge of the Mix Form.
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6. You may wish to modify the minimum and maximum settings relative to position
to get the right ‘feel’ and sound. Type in the appropriate numbers in the Min and
Max fields in the Mix Icon Properties – Controls tab for the Reverb control.
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7. Click OK when done.
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A Short Tour of GraphiMix Features
Here are some highlights of the most often used GraphiMix features.

Using the Keyboard and the Mouse
To move Mix Icons around the Mix Forms, use a <left click, drag, and release> on the
icon to be moved. A single <left click> on an icon causes it to be selected. A selected
Mix Icon is drawn with a red square surrounding it.

If the <space bar> on the keyboard is typed when a Mix Icon is selected, ‘Mouse Lock’
Mode is entered. The Mix Icon will be attached to any movement of the mouse without
having to hold down the left mouse button. Another <space bar> toggles this mode off.

The keyboard cursor keys, up, left, right, and down, will move the selected Mix Icon in
the appropriate direction. If the Mix Icon is on a rectangular Mix Form, then the icon
moves up, down, left and right. If the Mix Icon is on a radial Mix Form, then the icon
moves in and out in radius, and left and right in angular position. If the <control> key is
held down when the arrow keys are pressed, the Mix Icon moves in larger increments.

A <control-C> typed on the keyboard (or if copy is selected from the Edit menu) copies
the selected Mix Icon to the Windows clipboard. If no icon is selected then the selected
Mix Form is copied to the clipboard. A <control-X> ‘cuts’ the selected icon or Mix
Form and a <control-V> ‘pastes’ the contents of the Windows clipboard to the selected
Mix Form or Mix Frame. These actions can also be selected from the Edit menu.
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A selected Mix Form has the title bar drawn in blue. Any click on or within the Mix
Form boundary will select that Mix Form (provided some other Mix Form isn’t in the
way).

To move a Mix Form, <left click and drag> on the Mix Form’s title bar. To resize a Mix
Form, <left click and drag> on a corner or a side of the Mix Form. The cursor will
change to a double-arrowed symbol when it is over a ‘resize’ point.

A <right-click> on Mix Forms or Mix Icons brings up the appropriate context menus. If
GraphiMix is set to Build Mode, extra entries appear in these context menus. GraphiMix
is toggled between Run Mode and Build Mode by toggling the Run/Build Mode button
on the standard toolbar.

Standard Toolbar

Run Mode Build Mode
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This is a Mix Icon context menu.

‘Run’ mode ‘Build’ mode

This is a Mix Form context menu.

‘Run’ mode ‘Build’ mode

Mix Form and Mix Icon properties are displayed and modified by the selection of the
Properties entry.

The <shift> and <control> keys modify the operation of the Mouse buttons.
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A <shift-left click> toggles the Mix Icon in and out of ‘Solo’
mode. A Mix Icon in Solo Mode is drawn with a bright green halo.
MIDI messages can be sent when the icon enters or leaves solo
mode.

Solo mode typically ‘solos’ the track or bus so that it can be heard
by itself, temporarily removing all other ‘non-soloed’ tracks from
the mix.

A <shift-right click> toggles the Mix Icon in and out of ‘Mute’
mode. A Mix Icon in Mute Mode is drawn semi-transparently and
dim. MIDI messages can be sent when the icon enters or leaves
mute mode.

Mute mode typically ‘mutes’ the track or bus, temporarily
removing its contribution to the mix or monitors.

A <control-left click> is used to adjust the setting of a knob, fader or list control. If the
<control> key is not held down, the control’s position on the Mix Form is moved (via a
normal <left click and drag> operation). However, if the <control> key is held down, the
<left click and drag> operation is applied instead to the rotation of the knob or the
movement of the slider or the list entry selection.
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A <control-left click> on a switch toggles the state of
the switch.

Knobs, faders, and switch Mix Icons can be optionally set so that their position is fixed.
In this mode, the <control> key is not needed to adjust their fader, knob, or switch
positions when dragging. All switches used in the templates are set this way so that
the user can simply <left-click> on the switch or icon to change its state.

The <mouse wheel> is also used in GraphiMix.  If a Mix Icon is selected, the <mouse
wheel> moves the icon according to the Mix Icon movement constraints (set in its
properties dialog) and what kind of Mix Form it is placed on. If the Mix Icon is placed on
a stereo Mix Form (semi-circle), then the <mouse wheel> moves the selected icon in a
radial direction. On a normal Mix Icon with pan and volume controls, this would equate
to moving just the volume control with the wheel. A <Shift-mouse wheel> would move
the icon in an angular direction, i.e. adjust only the Pan control. If the control is placed on
a rectangular Mix Form, then the <mouse wheel> moves the icon in the Y direction (up
and down) and the <shift-mouse wheel> moves the icon in the X direction (side to side).
This provides a vernier-type of control which is useful in making small precise
adjustments.

A <control-mouse wheel> adjusts the Radius Mapping settings
for the selected Mix Icon. The Radius mapping setting allows the
user to provide more adjustment resolution near the high end or
the low end of the adjustment range as opposed to a strictly linear
mapping which provides constant resolution throughout the Mix
Icon range.

The <Delete> key will delete the selected object such as Mix Icons, Mix Forms, and
Links only if GraphiMix is in ‘Build’ mode.

Keyboard and Mouse Summary

Keyboard:

UP, DOWN, LEFT, RIGHT Move selected Mix Icon
accordingly.

UP, DOWN, LEFT, RIGHT Move selected Mix Icon
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+<Control> accordingly with larger steps

<Control-C> Copy the selected Mix Icon or the
selected Mix Form to the
clipboard.

<Control-X> Cut the selected Mix Icon or the
selected Mix Form to the
clipboard.

<Control-V> Paste from the clipboard.

SPACE Toggle ‘Mouse Lock Mode’ for
the selected Mix Icon.

DELETE Delete the selected object. Build
mode must be enabled in order to
use this key.

+,- Zoom in/out selected Mix Form.

Mouse:

Keyboard <Left Click> <Mouse Wheel> <Right Click>

-none- Select Mix Icon or
Mix Form.
Drag Mix Icon or
Mix Form.

Adjust Radius on
Stereo/Quad Mix
Form.
Adjust Y on
Rectangular Mix
Forms.

Context Menu for
Mix Icon or Mix
Form.

<Shift> Toggle Mix Icon in
Solo Mode.

Adjust Angle on
Stereo/Quad Mix
Form.
Adjust X on
Rectangular Mix
Forms.

Toggle Mix Icon in
Mute Mode.

<Control> Toggle Switch Mix
Icon.
Drag Knob and
Fader settings.

Adjust Radius
Mapping for Mix
Icon.

Context Menu for
Mix Icon or Mix
Form.
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Tiled Mix Form Display Mode
This is a useful feature that allows the user to most efficiently use and access the
GraphiMix mix surface. Most templates uses this mode for the most frequently accessed
Mix Forms.

This mode is accessed from the Window menu in GraphiMix.

A Mix Form can be a free-floating window of any size (inside the GraphiMix
mainframe), or it can be hidden, or it can be minimized, or it can be tiled. A tiled Mix
Form shares and fully occupies the GraphiMix application window frame with all other
tiled Mix Forms.
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By clicking and dragging on a side or top or bottom of a mix form that is tiled, the user
can change the size of the selected mix form and all other tiled mix forms will then re-
adjust their edges to fit the new size.
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When the mix form is released, the columns will readjust to accommodate the new size.
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There is a minimum column width and a minimum Mix Form height within a column.
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A Mix Form that is ‘rolled up’ to its minimum height or its minimum width is ‘sticky’ in
the sense that it will tend to stay minimized when the tiling is adjusted. For example, in
the following image, there is a stack of mix forms in the rightmost column with only two
mix forms ‘open’ and the rest ‘rolled-up’ to their minimum height.
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If the ‘Aux Bus’ Mix Form height is resized, the ‘Virtual Mains’ Mix Form will change
its height in return. All of the other Mix Forms in that column will remain ‘rolled-up’.

The same behavior will occur when the widths are adjusted.
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To move Mix Forms from column to column or to a different place in the same column,
simply drag the selected Mix Form to the new position and release it. It will
automatically retile into the appropriate place.
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Icon Controls
In order for GraphiMix to communicate with Midi hardware or software, the midi
protocols and control names must be contained in a VSL file that exists in the GraphiMix
VSL subdirectory.

Any control for any connected and supported hardware can be added to any Mix Icon on
any GraphiMix session. GraphiMix could easily control other external hardware while
connected and communicating with SONAR for example. The user can also link Mix
Icons together, so that an external piece of hardware can become a ‘controller’ for
SONAR or for a completely different external MIDI device.

This can allow for very powerful studio setups incorporating a variety of external
hardware mixers and/or software MIDI applications in a single GraphiMix session.

Small VSL files can be created by the user with a simple text editor to support any piece
of Midi equipment where the messages are documented (usually in the back of the
hardware manual). System exclusive (SYSEX) and Control change protocols are fully
supported.

For more information on the VSL language and format, see the GraphiMix Help or the
GraphiMix Reference Manual.
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Icon Properties
Icon properties are selected by performing a <right-click> on a Mix Icon and clicking on
“Properties” when in ‘Build’ mode. All of the properties that can be set on a per-icon
basis are set in this tabbed dialog. For more information see the GraphiMix Help or the
GraphiMix Reference Manual.

Mix Form Properties
Mix Form properties are selected by performing a <right-click> on a Mix Form and
clicking on “Properties” when in ‘Build’ mode.  All of the properties that can be set on a
per-mix form basis are set in this tabbed dialog. For more information see the GraphiMix
Help or the GraphiMix Reference Manual.

Scenes and States

GraphiMix incorporates a very powerful feature known as Scenes and States. Essentially,
the entire session can be ‘snapshot saved’ and cloned as a new state. Now controls can be
set in that state to different positions. By selecting the first state, all controls will be reset
to their original positions. By selecting the new state all controls will be set to their new
settings. Any number of states can be created. Scenes are essentially folders of States and
provide another grouping of related presets.

To use this feature,
1. First enable the Mix Form Tool bar and the Scenes and States Tab bar by using

the GraphiMix View menu.
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2. Now, click on the Create New State button on the Mix Form Toolbar.
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Note that the new state is an exact copy of the current state. Now, icons can be moved
around, Mix Forms added or deleted, or any other modification can be performed in this
new state. This state is essentially a ‘preset’ for GraphiMix.

The Scenes and States Tab bar displays 3 rows of tabs. The top row is the Mix Form tab
bar and shows all Mix Forms in the current state, even hidden ones, The appropriate Mix
Form will be ‘brought to the front’ and un-hidden if you click on the corresponding Mix
Form tab.

The second row of tabs is the State tab bar. Clicking on the appropriate tab will
instantiate the selected state, issuing MIDI for all active controls in this state. The states
can be renamed on this tab bar.

The third row of tabs at the bottom show the scene that is currently in effect. A scene is
essentially a container of states.

For more information on Scenes and States, see the GraphiMix Help or the GraphiMix
Reference Manual.

How to link Mix Icons
Mix Icons can be linked so that the movement of one ‘master’ Mix Icon controls the
position of one or more linked ‘slave’ icons. These links can be of various types such as
horizontal mirror, vertical mirror, same as (ganged), cross-fade, and many others.

To create a link,
1. First use the View menu to bring up the Mix Form Toolbar.

2. The Link button has a picture of a chain link on it. Click on this button to create a
link. The cursor changes to a ‘Link Master’ cursor.
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3. After selecting the ‘Master’ icon of the link, the cursor changes to a ‘Link Slave’
icon.

4. Click on the slave icon.

The Master and Slave Icons can be on different Mix Forms.

When the slave icon is selected, the Link Properties dialog automatically comes up to
determine which kind of link is desired.

A link can also be circular in the sense that the master icon can be a slave to its own
slave. This allows the movement of either icon to control the position of both. However,
an icon cannot have more than one master. To create a circular link (essentially two,
reverse-connected unidirectional links) , check the ‘Create a BiDirectional Link’ box in
the Link Properties Dialog.

To view links, click on the View menu and select ‘View Links’.
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To view the Link properties, <right-click. on the link line.

To delete a link, <left-click. on it. It should turn red. Then type the <delete> key. .

GraphiMix must be in ‘Build’ mode  before any object can be deleted.
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An example of connecting a hardware mix surface to GraphiMix
using links

Here is an example of cutting and pasting a Mix Form from a JLCooper CS10 session
into a SONAR session template. Each CS10 fader mix icon is linked to an appropriate
track Mix Icon using GraphiMix links. Adjusting the position of the CS10 faders will
similarly adjust the radius coordinate of each linked Mix Icon.
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Now, moving the physical faders on the JLCooper CS10 mix surface moves the
GraphiMix track mix icons and also moves the corresponding faders on the SONAR
console.

For more information on links, see the GraphiMix Help or the GraphiMix Reference
Manual.

Edit Preferences
To access the Edit Preferences dialog, click on the Edit menu and select ‘Preferences’.
This dialog provides global settings to tailor timing behaviors, CPU loading, whether to
load the last project, and others. In general, if GraphiMix is ‘sharing’ the CPU with other
software, e.g. SONAR or other MIDI applications, the ‘Responsiveness’ setting may
have to be decreased to 89 or below to give other processes a chance to run.
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For more information, see the GraphiMix Help or the GraphiMix Reference Manual.

Cut and Paste
Mix Icons can be ‘Cut’, ‘Copied’, and ‘Pasted’ to new Mix Forms or old. Often the best
way to create a new mix session is to create one icon that contains all the desired
controls. When this Mix Icon is completed, it can be ‘copied’ and ‘pasted’ to replicate it
for many tracks or channels. Find and Replace (see below) can be used to change certain
fields (like the channel or program register) for all controls attached to an icon. This
saves a lot of clicking, deleting, and typing when doing initial setups.

Mix Forms can also be ‘Cut’, ‘Copied’, and ‘Pasted’. To cut or paste a mix form using
the keyboard commands, make sure that no icon on the selected form has been selected
(red box around it), otherwise the selected icon, not the Mix Form, will be the target.

A <control-C> typed on the keyboard (or if copy is selected from the Edit menu) copies
the selected Mix Icon to the Windows clipboard. If no icon is selected then the selected
Mix Form is copied to the clipboard. A <control-X> ‘cuts’ the selected icon or Mix
Form and a <control-V> ‘pastes’ the contents of the Windows clipboard to the selected
Mix Form or Mix Frame. These actions can also be selected from the Edit menu.

To prevent confusing the attached hardware and yourself, disable MIDI when cutting and
pasting icons and mix forms. For example, if MIDI is not disabled (and is attached to an
application or a hardware mixer) and a Mix Icon is copied and pasted, the new icon will
show up on top of the old. Not only that, but any attempt to move one of the icons will
move the other identically because they are connected via MIDI to the same controls. To
separate the icons so that the controls on one can be edited to use a new track or channel,
disable the MIDI connection temporarily.

Find and Replace
The Find and Replace utility is designed to automate some of the work required to create
Mix Forms with arrays of (almost) identical Mix Icons with (almost) identical controls
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attached. To access Find and Replace, click on the Edit menu and select ‘Find and
Replace’.

Often, all the Mix Icons on a Mix Form will have an identical setup for attached controls
except that the Channel (or bus, or aux) number will change. Find and Replace allows
identical changes to be made to all controls on a given icon, all icons on a given Mix
Form, or on all Mix Forms in this state, or on all Mix Forms in this Scene. The search can
be automatic, or can be done as a ‘Query Replace’ where each eligible control is
displayed before the change is made.

For examples of using Find and Replace, see Quick Topics, Changing the Track
Number of a Mix Icon., page 15.

For more information, see the GraphiMix Help or the GraphiMix Reference Manual.

Radius Mapping
Radius Mapping is a feature that allows the user to customize how the position of the
icons maps into the actual setting of the attached controls.

The Flat Radius setting sets the radius where the icon’s controls (attached to the Radius
or Inverse Radius coordinates) goes to the minimum (or maximum) value. This is useful
to prevent ‘crowding’ when a lot of Mix Icons are set to the minimum (or maximum)
values. Now the icons will reach their minimum value before the radius goes to 0.

The Radius Mapping value changes the ‘shape’ of the position-to-value mapping from a
straight line (linear interpolation) to a family of curves.  These curves give more
resolution to certain areas of the control’s range. For instance, the user may want better
fine adjustment over the loud part of a volume control’s range and coarser control when
the volume is set lower. Or he may want just the opposite. The Radius Mapping
parameter allows the user to choose, on a per-icon basis, where he wants finer control.

The Radius Mapping and Flat Radius parameters can be set on the Edit Preferences
menu, on each Mix Form, or on each Mix Icon.
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The Edit Preferences dialog sets the default settings for these two parameters for each
new Mix Form.

The Radius Mapping tab in the Mix Form Properties dialog allows the user to set the Flat
Radius for the Mix Form (and all icons placed on that Mix Form), but only sets the
default setting of the Radius Mapping values for new Mix Icons added to this form.

The Radius Mapping tab in the Mix Icon Properties dialog allows the user to set the Flat
Radius for all icons on this Mix Form, and to set the Radius Mapping value for this Mix
Icon only. The Mix Icon’s Radius Mapping value can also be changed by selecting the
Mix Icon and then doing a <control-Mouse wheel> action.

For more information, see the GraphiMix Reference Manual.

Axes and Grids
GraphiMix provides a full-featured ability to create axis and grids on the Mix Forms
which provide a visual reference for the settings of the controls attached to the Mix Icons.
These axes can be logarithmic or linear in radius, angles, X, or Y, and can be drawn in
any color with arbitrary offsets and labeling. This feature is enabled in the Mix Form
Properties-Backgrounds dialog.

Calibrated Axes and Dynamic Status Displays
Axes are also used as calibration objects that can be used to finely calibrate the position
of a Mix Icon to a control setting on the attached hardware or software. Dynamic status
displays can be enabled for each icon which provide a small, dynamic, readout attached
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to the appropriate Mix Icon. Up to two calibrated controls’ values can be displayed
dynamically on each icon at various, selectable positions.

The display of the axes used as calibration objects can be inhibited, permitting only the
dynamic status display of calibrated settings. The calibration axes take into account any
Radius Mapping or Center Flat settings so that the dynamic status displays always
indicate the actual hardware (or software) setting.

For more information, see the GraphiMix Help or the GraphiMix Reference Manual.

Creating a Mix Session
To create a GraphiMix mix session, you must first have the MIDI driver files (VSL files)
that you need to drive the hardware that you will be working with. These files are in the
VSL subdirectory relative to the location of GraphiMix.exe.

Mix Session VSL Files

VSL files hold the MIDI message protocols to communicate to specific controls in the
hardware or application.

Several VSL files are included with the GraphiMix base application. These are:

VSL file Supports
PCMidi.VSL Sound Card MIDI commands
VygrInternal.VSL INTERNAL protocol commands to set

internal GraphiMix variables.

Each Support Package also contains one or more VSL files specific to the target hardware
or software.
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Create from Scratch or Copy and Modify?

There are two ways that a user can create a mix session. One is to start from scratch and
create a new Mix Session from the menus.  The second way is to copy an existing VOY
session file and delete, add, and modify until the session is to your liking.

For each of the included GraphiMix Support Packages there are session files which
provide initial configurations that control the target hardware available for a user to copy,
prune, and customize. These should be copied and only the copies modified. Do not
modify the template VOY files if you want to keep these as reference sessions.

To read in an existing VOY session, start the GraphiMix application, then click on the
File Menu and select Open. Navigate to the directory where the session files are stored
and select the desired file. This may be the directory where the GraphiMix application
was installed or another directory. Alternatively, the user can double-click on a VOY file,
which will start the GraphiMix application with the selected VOY file.

To create a session from scratch, start GraphiMix by double-clicking GraphiMix.exe icon
in the GraphiMix Program Start Menu.

Choose Mix Form Type
After startup and the initial GraphiMix ‘splash’ screen disappears, you will see a blank
stereo Mix Form.  Right-click on the Mix Form and select ‘Properties’ to change the Mix
Form type.

 For stereo work leave the Mix Form type set to Stereo. Other choices are Surround,
Stereo Rectangular, and Surround Rectangular.
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Select  Mix Icons
Pull down the View Menu and select ‘View Icon Windows …’.

Select Primary or one or more of the other icon directories.

Choose the Mix Icons that you will need by ‘left-click and dragging’ them to the Mix
Form from the Mix Icon Selection Window.

To create or modify Mix Icons, use the Tools Menu and select ‘Edit/Create Mix Icon
Images…’. With this tool, one can create or modify Mix Icons from Windows Bitmap
Files (BMPs) or from text, or the user may create custom knob and fader icons.

Mix Icons can also be used as labels on the Mix Form. They can be ‘locked’ in place and
disabled from selection. To ‘lock’ them in place, right click on the Icon and select the
Mix Icon Properties Tab. On this dialog select ‘Fixed Position’ for the constraint. To be
disabled from selection (by a left-click) uncheck the ‘Allow Left Click’ checkbox. Select
OK to exit this dialog.

Other Mix Icon movement constraints can be selected to limit an icon’s movement on the
Mix Form.

Attach Controls
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The next step is to ‘attach’ controls to the Mix Icon so that moving the Mix Icon causes a
change in the mix hardware. This is done by ‘right-clicking’ on the Mix Icon, selecting
Properties, and then selecting the Controls tab.

Initially, there are no controls shown on this dialog. Click on the button to insert one.
Now select the MIDI driver (VSL file) that holds the desired control. Then select the
Component name such as ‘Level’. If the VSL file has no component names, the
component field will say ‘<default>’. Now select the Control from a list of controls
shown in this component.

After the Control has been selected, the Description text field should show useful
information such as the type of MIDI command it is and how its value is set.  In this case,
it says that the ‘Value is set from Mix Icon Coordinate’, which is set to ‘InverseRadius’.

Depending on how the VSL for the control is written, the value can be set from the Mix
Icon Coordinate (and Data Type) or it can be set in one or more of the other fields in the
Controls dialog. Values can be optionally set (and used in the sent message) in ‘Index’,
the ‘Parameter’, or the ‘Program’ fields. The MIDI channel used to communicate to this
control must also be set in this dialog.

If the control value is set from the Mix Icon Coordinate, then both the Coordinate and the
Data Type must be set appropriately. For a fader-type or level control, the Data Type
field should be set to ‘Fader’. For a pan pot or balance control, the Data Type field should
be set to ‘PanPot’. Other Data Type selections are for an input-by-output bus matrix of
faders. These Data Types allow the user to simulate a fader/panpot combination with two
discrete faders, or to simulate a surround mix with 4 or more discrete faders.
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Choose the Mix Icon Coordinate that the control should be ‘attached’ to. For a stereo
fader-type control, the coordinate chosen is usually ‘InverseRadius’ (loudest at center).

Similarly, the user would normally attach a pan pot control to the ‘Theta’ coordinate to
the same Mix Icon.  This creates the standard GraphiMix ‘Pan-Fader’ type of Mix Icon.
For more information on Mix Icon controls, see the GraphiMix Reference Manual.

Mix Icons and Mix Forms can be cut, copied, and pasted to and from the windows
clipboard by selecting the appropriate options in the ‘Edit’ menu. Remember to highlight
(select) the appropriate target first.  If an icon is selected (red box around it) then it is
selected for cut and paste. Otherwise the highlighted Mix Form is selected.  The standard
windows behavior for <control-C>(copy), <control-X>(cut), and <control-V>(paste) are
supported.

A common way of cloning controls to make multiple channels of identical tracks would
be to set up one Mix Icon with all its names and attached controls. Then cut and paste a
copy of this icon, and change the Component field for each of the controls on the new
icon to the next desired channel using Find and Replace.

If a switch-type Mix Icon is selected, several new coordinates, SwitchToOn and
SwitchToOff, appear in the Coordinate drop-down list.

On and Off controls can be attached to these coordinates to implement a switch control.
In the above example, two instances of the same control would be attached to the same
Mix Icon, one to send the ‘Pre’ state, the other to send the ‘Post’ state.

To switch the state of a switch-type Mix Icon, hold the <control>key down and left click
on the icon. Since the value for the control setting is set in the ‘Parameter’ entry and not
by the Mix Icon Coordinate, the setting for Data Type is irrelevant. Unlike other
coordinate selections, the ‘SwitchToOn’ and ‘SwitchToOff’ coordinates only ‘fire’ when
those events are true. This insures that only one of the two attached controls fires on each
switch state.
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The switch Mix Icon can also be put into a mode where the <control> key is not required;
a simple left-click will toggle the switch. Certain other types of Mix Icons have the same
feature.

When MIDI input is received which matches the MIDI sequence for a SwitchToOn
control, the mix icon will automatically enter the On state and will be displayed with the
ON state image.  Similarly when a mix icon is in the ON state and MIDI is received
which matches a control assigned to SwitchToOff, then the mix icon enters the OFF state
and is displayed with the OFF state image.

Other types of controls can be attached to the normal Mix Icon coordinates (Radius,
Theta, etc) in addition, allowing the movement of the switch on the Mix Form as well as
the switch state to set controls. For more information on switch Mix Icons, refer to the
GraphiMix Reference Manual.

If a fader or knob-type Mix Icon is selected, two other new coordinates, Fader and
InverseFader, will appear in the Coordinate drop-down list.

Controls can be attached to these coordinates to allow the position of the knob on the
fader to set controls as well as where the Mix Icon is placed on the Mix Form. Of course,
any type of Mix Icon, including switches, faders and knobs, can be constrained to ‘Fixed
Position’ which ‘locks them down’ on the Mix Form if desired.

To adjust the value of the fader or knob, hold the <control> key down and then left-click
and drag the fader to the desired position. For more detail on knobs and faders, refer to
the GraphiMix Reference Manual.

The knob and fader Mix Icons can also be put into a mode where the <control> key is not
required; a simple left-click-and-drag will operate the control. The change in position of
the Mix Icon on the Mix Form is inhibited in this mode.
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Solo and Mute

The ‘SoloOn’ and ‘SoloOff’ coordinate selections allow the user to solo a given
instrument.  A mix icon toggles its solo mode when the user shift-clicks on the mix icon.
A mix icon which is in solo mode is shown with a bright green halo. Solo mode typically
‘solos’ the track or bus so that it can be heard by itself, temporarily removing all other
‘non-soloed’ tracks from the mix.

When the user causes a mix icon to enter the SoloOn state by using a shift-click, any
control which is assigned to the SoloOn will output its MIDI.  Similarly when the user
causes the mix icon to enter the SoloOff state, any control which is assigned to SoloOff
will issue its MIDI.

The ‘MuteOn’ and ‘MuteOff’ coordinate selections allow the user to mute a given
instrument.  A mix icon toggles its mute mode when the user shift-clicks on the mix icon.
A mix icon which is in mute mode is shown as semi-transparent. Mute mode typically
‘mutes’ the track or bus, temporarily removing its contribution to the mix or monitors.

When the user causes a mix icon to enter the MuteOn state by using a shift-right click,
any control which is assigned to the MuteOn will output its MIDI.  Similarly when the
user causes the mix icon to enter the MuteOff state, any control which is assigned to
MuteOff will issue its MIDI.

When MIDI input which matches the MIDI sequence for a MuteOn control is received,
the mix icon will automatically enter the MuteOn state and will be displayed as semi-
transparent.  Similarly when a mix icon is in the MuteOn state and MIDI is received
which matches a control assigned to MuteOff, then the mix icon enters the MuteOff state
and is displayed normally.

Solo and Mute modes can also be set by using the Mix Icon context menu (right-click on
Mix Icon).
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Add More Mix Forms

Additional Mix Forms can be added to a session by opening the ‘Insert’ menu and
selecting ‘New Mix Form’, or by using the Mix Form Tool Bar.

A Mix Form can also be replicated by selecting the Edit Menu->Copy Mix Form entry or
typing <control-C>. The Mix Form that is currently selected is then copied to the
windows clipboard.  If a Mix Icon is selected (red box around it) it will be necessary to
de-select it first (click on a blank area of the Mix Form).

Paste the Mix Form to the same or different Scene or State by selecting the Edit Menu-
>Paste Mix Form or by typing <control-V>.

Enable MIDI

Finally, enable MIDI by selecting the MIDI Menu->Select Midi Devices… dialog. There
are primary and secondary MIDI device selections that allow GraphiMix to send and
receive to two different MIDI ports at the same time. Select the appropriate MIDI port
that is attached to your Mix hardware. For more details on MIDI and the GraphiMix, see
the GraphiMix Help or the GraphiMix Reference Manual.

Runtime Status Display

The positional status of a selected Mix Icon can be shown by selecting the View Icon
Status in the View menu. This window shows the ‘values’ for each of the attached
controls, the name and image of the selected Mix Icon, and the X, Y, Radius and the
Theta Mix Form coordinates.  The image of the selected icon appears in the upper left
corner of this display.
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Installation and Licensing

Installation and Licensing for a Web Download.
You may download a 24 day free trial of GraphiMixPro from www.voyagersound.com.
You may also download and install free trials of any of the available support packages.

The GraphiMix software consists of two elements, the basic GraphiMix Engine, and,
optionally, one or more Support Packages. The GraphiMix Engine is the basic graphic
user interface toolkit which allows the user to create his own VSL midi drivers and
template files. Each Support Package adds the files and drivers required to interface with
a specific console or digital audio workstation or other software or hardware applications.

To use the GraphiMix software, the basic GraphiMix engine and, optionally, one or more
support packages must be installed and licensed.

First, download or otherwise obtain the self-extracting executable file and copy it to a
temporary directory. This file will be named according to which product variant you are
installing. GraphiMix install files are available for the base Engine only, for the support
packages only (no engine), or as a combination of the base Engine plus one support
package.

Note: If a previous version of Voyager GraphiMix is installed, you must remove it first
by using the ‘Add/Remove Programs’ application in the Control Panel window. To get
free updates for one year, simply download the new version of the same configuration
originally purchased. An update will not require re-licensing.

Run the downloaded executable by double-clicking on its icon in the directory window.
Follow the installation directions.

Note: On rare occasion, the GraphiMix installer may issue a message that it cannot install because it is
missing some Microsoft Installer components. If this message occurs, it will be necessary to download the
Microsoft Installer from Microsoft’s website http://www.microsoft.com/downloads (Search for ‘Windows
Installer’). Exit from the GraphiMix installer first. Then download and install this update from Microsoft. It
will be necessary to reboot your computer after installing. Once this has been done, restart the Voyager
installer and continue. If problems continue, check the FAQ on our website, or e-mail
support@VoyagerSound.com.

After you have finished installing GraphiMix, it will be enabled with all features and
support packages (they must be downloaded and installed to be accessible) for a single
initial 24 day free trial period.

Only one such 24 day free trial period is allowed. After this trial period, GraphiMix must
be licensed in order to run.
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When you have decided to purchase a license for GraphiMix and/or any of the support
packages, use the following steps if you are on the computer that will be licensed and it is
connected to the internet. If you are not on the computer that will be licensed or the
computer to be licensed is not connected to the internet, follow the instructions in the
Manual Licensing Procedure using Email section, page 91.

Additional Support Packages may be downloaded and a free license obtained that runs
for 10 days. To obtain a free 10 day trial license see section Obtaining a Free Trial
License for a Support Package, page 92.

Step 1 – Visit www.voyagersound.com and click on the ‘Shop’ button.

Step 2 – Follow the instructions on the web site to purchase the product.  When you
purchase the product you will receive a purchase number.

Step 3 – Run GraphiMix, pull down the Help Menu and select ‘License’. The License
Status dialog will come up.  Click on the ‘Get a License’ button.

Step 4 – Click on the ‘Get Site Key Over the Internet’ button.

Remaining Steps – Follow directions on the dialog boxes. You will need your purchase
number.

Manual Licensing Procedure using Email
If you are on a different computer from the one to be licensed you must do the following
instead:
When you have decided to purchase a license for GraphiMix and/or any of the support
packages, use the following steps:

Step 1 – Visit www.voyagersound.com and click on the ‘Shop’ button.

Step 2 – Follow the instructions on the web site to purchase the product.  When you
purchase the product you will receive a purchase number.

Step 3 – Run GraphiMix on the computer where you want your licensed version of
GraphiMix to run, and select ‘License…’ from the Help menu.
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Step 4 – Your Site Code will be displayed. A site code is a number which is unique to
your computer.

Step 5 – Send email to registration@voyagersound.com. The subject should be
‘MANUALREGISTRATION’ and the text of the mail should have the target computer’s
site code on the first line and your purchase number on the second line, as shown below.
Do not place any other text in this message.

Step 6 – You will receive email from Voyager sound with your Site Key.  The Site Key
will unlock the purchased feature on your computer. When you receive the email, run
GraphiMix again, select ‘License…’ from the Help menu, enter your site key, and click
the ‘Apply Site Key’ button.  Your product is now licensed for used.

Obtaining a Free Trial License for a Support Package
Additional Support Packages can be downloaded and ‘tried out’ with a licensed
GraphiMix application with a single-use 10 Day Free Trial License.

This license can only be used with one Support Package at a time.
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Additional Free Trial Licenses can be obtained for other Support Packages, but each new
license will terminate the previous free trial license. Any other, purchased, licenses are
unaffected.

To obtain a 10 Day Free Trial license, use the following steps.
Step 1 – Visit www.voyagersound.com and download the desired Support Package.

Step 2 – Run GraphiMix on the computer where you want your Support Package to run,
and select ‘License…’ from the Help menu.

Step 4 – Your Site Code will be displayed. A site code is a number which is unique to
your computer.

Step 6 – Click on the Support Package to be trialed.
Step 7 – Click on the ‘Get Free Trial’ button.

The Site Code will change to the Free Trial Site Code.

If the computer to be licensed is connected to the internet, click on the ‘Get Free Trial
Site Key’. Follow instructions.

If the computer to be licensed is not connected to the internet, follow the manual
licensing instructions in the section, Free Trial Licensing Procedure using Email, page
94.
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Free Trial Licensing Procedure using Email

Step 1 – Send email to registration@voyagersound.com. The subject should be
‘MANUALFREETRIAL’ and the text of the mail should have the target computer’s Free
Trial Site Code on the first line and your purchase number on the second line, as shown
below. Do not place any other text in this message.

Step 2 – You will receive email from Voyager sound with your Site Key.  The Site Key
will unlock the purchased feature on your computer.

When you receive the email,
1. Run GraphiMix again.
2. Select ‘License…’ from the Help menu.
3. Highlight the selected Support Package.
4. Click on ‘Get Free Trial Site Key’.
5. Enter your Free Trial Site key, and,
6. click the ‘Apply Site Key’ button.

Your product is now licensed for use for 10 days.
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Transferring a License to another computer
You may move your GraphiMix license along with any support package licenses from
one computer to another as often as you want.  Free Trial licenses are not transferable.

In order to move your license from a licensed source computer to an unlicensed target
computer, use the following steps:

Step 1 – On the target computer, install GraphiMix and any required support packages if
you have not already done so.

Step 2 – On the target computer, if you are in the initial 24 day free trial period, you must
first destroy your 24 day trial period license. In order to do this, select ‘License Transfer’
from the Help menu and then click the button labeled ‘Kill License and Get Code To
Prove That License Has Been Killed’. You can ignore the kill code. You will not need it.

Step 3 – While still on the target machine, re-run GraphiMix. The License Status dialog
box will automatically come up because GraphiMix is unlicensed.

Step 4 – Put a blank floppy disk into the computer and click the button labeled ‘Prepare
Floppy to Import License to This Computer’. Note: The floppy disk will appear empty.
There will be no files written to the floppy. Using ‘Quick Format’ on the floppy first will
clear all data and allow the floppy to be used for this purpose.

Step 5 – Now bring the floppy to the source computer which does have a license, run
GraphiMixPro and select ‘License Transfer’ from the Help menu.

Step 6 – Insert the floppy into the source computer and click the button labeled ‘Move
License Out of This Computer To a Prepared Floppy’.

Step 7 – Take the floppy to the target computer and click the button labeled ‘Transfer
License from Floppy Into This Computer’.

The license has now been moved from the source computer to the target computer.
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Example of Transferring the License between Home and Work
Computers
To transfer your GraphiMix license between a ‘home’ computer and a ‘work’ computer,
follow these instructions.

First time preparation
Obtain two floppy disks and label one ‘Home’ and the other ‘Work’. You may use
‘Quick Format’ in Windows to clear them of data and to allow them to be used for this
purpose.

The unlicensed computer must not be in the initial 24 day free trial period. To clear the
trial license, run GraphiMix and pull down the Help menu. Select ‘Transfer License…’.
Now click on the button labeled ‘Kill License and Get Code to Prove That License Has
Been Killed’. Ignore the kill code, you will not need it.

Step 1 - On the ‘Home’ computer (initially unlicensed), put the floppy labeled ‘Home’ in
the drive and run GraphiMix.

Step 2 - The License Status dialog will come up. Click on ‘Transfer License…’.

Step 3 - The License Transfer dialog will come up. Click on the button labeled ‘Prepare
Floppy to Import License to This Computer’. Let it finish, exit GraphiMix and remove
the floppy.

Transfer procedure from Work to Home

Step 1 – On the ‘Work’ computer, put the floppy disk labeled ‘Home’ in the drive and
click on the GraphiMix ‘Help’ menu. Select ‘Transfer License…’.

Step 2 – On the ‘Work’ computer, click on the button labeled ‘Move License Out of This
Computer To a Prepared Floppy’. Let it finish, and remove the floppy. This copy of
GraphiMix is now unlicensed.

Step 3 – Still on the ‘Work’ computer, put the floppy labeled ‘Work’ in the drive, and
click the button labeled ‘Prepare Floppy to Import License to this computer’. Let it finish
and remove the disk. This disk will be used to ‘bring the license back’ to this computer.

Step 4 – On the ‘Home’ computer, start GraphiMix, and put the floppy labeled ‘Home’ in
the drive.

Step 5 – The License Status dialog will come up. Click on ‘Transfer License…’.

Step 6 – The License Transfer dialog will come up. Click on the button labeled ‘Transfer
License from Floppy Into This Computer’. Let it finish. GraphiMix is now licensed.
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Transfer procedure from Home to Work
To move the license back to the work computer, follow these steps.

Step 1 – Put the floppy labeled ‘Work’ in the drive. This floppy has been prepared to
move a license to the work computer as outlined in Step 3 above.

Step 2 – Run GraphiMix on the ‘Home’ computer and pull down the Help Menu. Select
‘Transfer License…’.

Step 3 – In the License Transfer dialog, click on ‘Move License Out of This Computer
To a Prepared Floppy’. Let it Finish and remove the disk. This copy of GraphiMix is now
unlicensed.

Step 4 – Still on the ‘Home’ computer, put the floppy labeled ‘Home’ in the drive, and
click the button labeled ‘Prepare Floppy to Import License to this computer’. Let it finish
and remove the disk. This disk will be used to ‘bring the license back’ to this computer.

Step 5 – On the ‘Work’ computer, start GraphiMix, and put the floppy labeled ‘Work’ in
the drive.

Step 6 – The License Status dialog will come up. Click on ‘Transfer License’.

Step 7 – The License Transfer dialog will come up. Click on the button labeled ‘Transfer
License from Floppy Into This Computer’. Let it finish. GraphiMix is now licensed on
the ‘Work’ computer.

These procedures can be executed any number of times to move a license between
computers.

Installing and Configuring MIDI Yoke™
MIDI Yoke™ and MIDI-OX™ are useful MIDI utilities that some users may find very
useful when creating GraphiMix VSL files or when using multiple MIDI applications at
the same time on the same PC.  MIDI Yoke™ is included with the GraphiMix™ install.
There are two different versions included. One version supports Windows 95/98/ME
systems and the other supports Windows NT/2000/XP systems.

To install MIDI Yoke™, click on the Start menu and navigate to Programs->Voyager
Sound GraphiMix. Click on the “MIDI Yoke Install” icon. This runs a script that leads
you through the installation of MIDI Yoke on the particular Windows platform that you
are running. Follow directions.

GraphiMix Support Packages
The GraphiMix software consists of two elements, the basic GraphiMix Engine, and,
optionally, one or more Support Packages. The GraphiMix Engine is the basic graphic
user interface toolkit which allows the user to create his own VSL midi drivers and
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template files. Each Support Package adds the files and drivers required to interface with
a specific console or digital audio workstation or other software or hardware applications.

To use the GraphiMix software, the basic GraphiMix engine and, optionally, one or more
support packages must be installed and licensed.

Packages currently available include support for the Soundcraft 324, Soundcraft 328,
Tascam DM24, Cakewalk SONAR, and the Yamaha DME32. Others are in development
and will be available shortly.

Frequently Asked Questions

Q1: I lost my GraphiMix license somehow! What do I do now?
A1: Contact support@voyagersound.com giving the site code of your computer and an
explanation of how the license was lost.

Q2: Why do I sometimes lose my GraphiMix License!!!! I run Norton Speed Disk or
Defrag and after I run it, GraphiMixPro says it is not licensed.
A2: The interaction with Speed Disk is the problem. It can move the location of the
license files, invalidating the Site Code. However, there is a very easy solution which
allows for the continued use of Speed Disk. Here is the procedure to prevent Speed Disk
from causing a problem:

1. Open Norton Speed Disk.
2. Select "File / Options / Customize / Unmovable Files." from the Speed Disk

Menus.
3. Specify that *.ENT, *.KEY and *.RST files cannot be moved.
4. Remember to perform a "File / Options / Optimization / Save" from the Speed

Disk Menus.
5. You're done! That should configure Speed Disk so that it does not move the

License

Things NOT to do:
DO NOT move the program once it's installed without using the 'transfer license' option
from the License Transfer dialog box.

DO NOT change the date backwards in time. This is only for the 24-day trial period.
DO NOT erase any hidden files in the installation directory.
DO NOT uninstall if you plan on using the program again without first transferring the
license to a disk or to a different computer.

DO NOT run Norton Utilities Speed Disk without changing the settings:
1. Open Speed Disk and choose File|Options|Customize|Unmovable Files.
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2. Specify that the *.ENT, *.KEY and *.RST files cannot be moved and then Speed
Disk can be run without having any affect on CrypKey licensing. The *.41S files
do not need to be specified.

3. Remember to do a File|Options|Optimization|Save in order to save the new
profile.

DO NOT convert from a Win95 machine with FAT16 to a Win98 machine with FAT32
without first transferring the GraphiMixPro license, otherwise this will corrupt the
CrypKey and result in losing the license. You need to do the following:

1. Transfer the CrypKey license to another machine, using direct of floppy transfer.

2. Do the conversion

3. Transfer the CrypKey license back.
This procedure is necessary one time only, for this particular conversion.

License Agreement
NOTICE
Copyright (c) 1993-2007 Voyager Sound, Inc.

Voyager Sound and GraphiMix are trademarks of Voyager Sound, Inc.

This software is licensed to you under the terms and conditions stated in the License
Agreement.  Use of this software constitutes your acceptance of the terms of the license

agreement.  Please read the license agreement carefully before using this program.

Unauthorized reproduction or distribution of any material or programming contents
contained in this software is prohibited.

LICENSE AGREEMENT
Do not use this software until you have carefully read the following Agreement.  This
Agreement sets forth the terms and conditions for licensing of the software from Voyager
Sound, Inc. to you (“you” or “Licensor”), and using the software indicates that you have
read and understand this Agreement and accept its terms and conditions.  If you do not
agree with the terms and conditions of this Agreement, promptly return the software to
Voyager Sound, Inc.

This program is protected under United States copyright laws and trade secret laws.
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“Software” is defined as (1) the Voyager Sound, Inc. computer program with which this
License Agreement is included; and (2) any third party content accessible through the
software (“Content”).

License Grant
You are granted a limited non-exclusive license to use a copy of the Software on one (1)
computer.  You may make one backup copy of the Software for your own use.  Making
additional copies or duplicating the software by any other means including electronic
transmission is illegal.  It is also prohibited to give copies to another person.  You may
not copy the printed materials if any, accompanying the Software, or print copies of any
user documentation.  The Software also contains proprietary information and the trade
secrets of Voyager Sound, Inc. and third parties, and you may not de-compile, reverse
engineer, disassemble, or otherwise reduce the software to human-perceivable form or
disclose such trade secrets or proprietary information.  You may not modify, adapt,
translate, rent, sublicense, assign, loan, resell for profit, distribute, or network the
software, diskette(s), or related materials or create derivative works based upon the
Software or any part thereof.  You may transfer your rights in the Software to a third
party, or sell the computer on which the software is installed to a third party, provided
you do not keep a copy of the Software for yourself.  Voyager Sound, Inc. shall have the
right to change or add to the terms of the license at any time and to change, discontinue
or impose conditions on any aspect of the Software.  Such changes shall be effective
upon notification by any means reasonable to give you actual or constructive notice.

Disclaimer of Warranties
Except as provided above, this software, content, and/or any related services are provided
“as-is,” and to the maximum extent permitted by applicable law, Voyager Sound, Inc.
and its subsidiaries, affiliates, licensors, participating financial institutions, third-party
content providers, distributors, dealers or suppliers (“representatives”) disclaim all other
representations and warranties, express or implied, regarding this software, diskette(s),
related materials and any services, including their fitness for a  particular purpose, their
quality, their merchantability, or their non-infringement.  Voyager Sound, Inc. does not
warrant that the software is free from bugs, viruses, errors, or other program limitations,
including but not limited to accurate or updated third-party content.

Limitation of Liability and Damages

The entire liability of Voyager Sound, Inc. for any reason shall be limited to the amount
paid by the customer for the software licensed from Voyager Sound, Inc. to the maximum
extent permitted by applicable law, Voyager Sound, Inc. and its  representatives are not
liable for any indirect, special, incidental, consequential, or other damages.
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Patents and Copyrights
Voyager Mix GraphiMix® Copyright © 1993 - 2003 by Voyager Sound, Inc.
All rights reserved.
Applicable patent laws for the US and Europe applies.

Voyager Sound has US & Foreign Patents which protect this intellectual property.
U.S. Patent 5,212,733
Foreign Patent  0517848

All Voyager screens, literature and graphic material are Copyrighted, ©1993-2003
Voyager Sound Inc. of Weston, Massachusetts.

Please contact Voyager for license info.
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Appendix

About This Manual
This manual is provided with the release and is available in the GraphiMix install
directory as GraphiMixUsersGuide.pdf.

Acknowledgements
Certain passages are excerpted from “Maximum MIDI: Music applications in C++ by
Paul Messick. ©  Manning Publications Co. 1998.’’

The applications, MaxSeq and MidiSpy are authored by Paul Messick. ©  Manning
Publications Co. 1998.  The Voyager Sound applications, GraphiSeq and GraphiSpy are
adapted from these and have been extensively modified.

The MIDI file, 'bach_air_on_g_string_bwv1068.mid' is provided to run the GraphiMix
demo/tutorial. This file is a  sequence (c) Pierre R. Schwob - by permission. Original
from the The Classical Archives.

Contact Information
Due to this free shareware opportunity, support will be given to those who submit a
shareware fee of $25 (US) sent via  US post.  Please include your email address. You will
be sent a receipt.

To send us a postal letter, send it to:

Support
Voyager Sound Inc

P.O. Box 115
Weston, MA. 02493  U.S.A.
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Glossary and Definitions
ACTIVE REGION The area of the Mix Form between the Mix Form

Origin and the 100% Radius coordinate (on a Stereo
Mix Form) or the +/- 100% X and Y coordinates. The
area outside the Active Region has the Radius
Coordinate set at 100%. The X and Y coordinates are
similarly ‘pinned’ at their maximum and minimum
settings.

BMP An abbreviation for a Windows Bitmap File.

CHANNEL A single input to an audio console. Also, in MIDI, a
number between 1 and 16 that specifies the MIDI
channel for the communication.

CLICK A press of a mouse button.

CLIPBOARD A Windows feature. The user can ‘cut’ or ‘copy’ to the
clipboard, then possibly select a different window or
application, and finally ‘paste’ the clipboard object on
the to the destination.

CONSTRAINT Mix Icon movement on the Mix Form can be limited
in certain ways. For example, the Mix Icon can be
allowed to move up and down only and not side-to-
side. In this case the movement constraint would be
‘ConstantX’, it can only change the Y coordinate. The
‘Fixed Position’ constraint does not allow the Mix
Icon to move at all.

CONTROL A control is usually a piece of hardware that allows
the user to manipulate some parameter of the audio
production. A volume control or fader that receives
input from a source of audio and outputs to a single
bus would be an example of a control. Any
mechanism that allows the user to manipulate some
parameter of an audio mix would be a control.

CONTROL RECIPE A specification or ‘recipe’ that describes how a control
can be communicated with. It effectively describes the
message protocol to a particular control. These
message protocols are designed by the companies that
manufacture the hardware or software. Most of the
time, these protocols are described in the equipment
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manuals.
The Control Recipe describes how to construct a
particular message, using the GraphiMix™ VSL
language These recipes usually include constants that
indicate which control is being addressed, and over
what channel, as well as numbers that indicate the
setting to be applied.

CONTROL-KEY The Control Key on the PC keyboard is usually
located at the lower left and right bottom corners. A
Control-Key command involves holding the Control
Key down while pressing another key or clicking the
mouse.

DIALOG A Dialog is a Menu screen put up by GraphiMix™ to
allow the user to set and select various parameters. A
Dialog Box is a single entry on a Dialog menu screen.

DOUBLE-CLICK Two rapid mouse clicks in sequence. The threshold
that defines the difference between two single clicks
and a double click can be set using the Windows
operating system.

DOWNLOAD When the user is connected to the Internet, he can
browse to web sites which enable him to copy files
from a remote computer to his own, local computer.
This process is referred to as a download.

EFFECTS Controls which modify the sound and add filtering and
reverberation are called audio effects.

EMAIL Electronic mail that can be sent from the users
computer to other computers by using the Internet.

EQ EQ is short for Equalization. Equalization usually
means modifying the audio work by filtering and not
by adding effects, such as reverberation.

EVENT When a Mix Icon changes state, either by moving its
position or changing its internal states such as a switch
changing from On to Off, an event is generated. This
event usually results in a message being sent to all of
the Controls which are attached to the selected Mix
Icon if the event represents a change to the particular
control.



116

EXECUTABLE An executable is a file with the filename extension
‘.EXE’. These files usually represent programs and
applications that are ‘run’ by the user.

FADER A fader usually refers to a type of volume control that
slides up and down (or side to side) in a linear fashion.
A ‘knob’ would be a volume control that works in a
rotary fashion.

FEEDBACK LOOP A feedback loop is created when an output of a system
is fed back into the input. An example would be when
a microphone on stage gets too close to the speaker
which usually results in a loud squeal.
With MIDI, it is possible to hook a MIDI input to the
same MIDI output which can result in erroneous
operation. MIDI Yoke™ includes a mechanism to
detect MIDI feedback and will disable its port if it is
detected.

FIELD A field usually holds a number or a character string. In
dialog menus, there are usually fields that hold an
individual selection of a number or a name which can
be changed by the user.

FONT A font selects the ‘style’ of alphanumeric character
text. ‘Times New Roman’ and ‘Arial’ are examples of
font names.

GLASS CONSOLE A ‘Glass console’ is a software application that
provides control of a hardware or software audio
console by representing the individual controls as a
simulation of a hardware console. The on-screen
adjustments are made by adjusting graphic faders,
switches, and knobs with the mouse.

GRAPHIC MIX The Voyager Sound Graphic Mix is a new and unique
way to control hardware and software consoles using
Mix Icon graphics placed on multiple Mix Forms.
Each Mix Icon changes the settings of several attached
controls with a single movement, greatly multiplying
the ability of the sound mix engineer to interactively
control the mix on a computer screen.

GRAPHIC USER INTERFACE A Graphic User Interface is a system of on-screen
displays and mouse and keyboard interactions that
provide a way for the user to specify actions to the
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computer. An example of a Graphic User Interface
(abbreviated as GUI) is the Windows Operating
System.

HARDWARE CONTROL A hardware control is usually a piece of electronics
that processes and modifies audio signals in a way that
can be changed according to the engineer’s
requirements. A hardware control can be as simple as
a knob or fader potentiometer, physically moved by
the engineer, or as complex as a software algorithm
encoded into a digital audio processing device.

KNOB A knob is a rotary device that changes one or more
mix parameters.

LICENSE NUMBER The Voyager Sound GraphiMix™ requires a ‘Site
Key’ license number to enable use beyond the initial
24 day Free Trial Period.

LINK A link is a connection from a ‘Master’ Mix Icon to
one or more ‘Slave’ Mix Icons. The position of the
Slave Mix Icons is controlled by the position of the
Master Mix Icons and by the linking rules that
determine what the positional relationship is. Various
linking rules can be specified by the user.

MENU A Menu is a page that ‘drops’ down or otherwise
appears to allow the user to select various options or
parameters from a ‘menu’ of options or parameters.

MIDI The Musical Instrument Digital Interface (MIDI) was
invented in the early 1980’s by a group of synthesizer
manufacturers as a way to connect instruments
together to make sound. Since then it has evolved into
the protocol of choice for controlling everything from
sound synthesizers to tape machines.
MIDI is a communications protocol consisting of
messages that consist of as few as 1 byte and up to
thousands of bytes.

MIDI INPUT A device or application that can receive and act upon
MIDI messages must have its MIDI Input source
selected.

MIDI OUTPUT A device or application that can send MIDI messages
to other devices or applications must have the
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appropriate MIDI Output device specified.

MIDI PORT A MIDI port is a hardware or software device that
sends and receives MIDI messages to external
hardware or other software applications.

MIDI SEQUENCER A MIDI sequencer is like a ‘tape recorder’ for MIDI.
It receives and stores sequences of MIDI messages
and can then ‘Play them back’. Some sequencers allow
the engineer to modify the stored sequences and add
more sequences to different tracks to allow the
engineer to build up large multi-track compositions.

MIDI THRU Some MIDI devices can receive MIDI messages from
other devices and then ‘pass them on’ to its MIDI
output, mixed with its own MIDI messages. This
mode of operation is known as ‘MIDI Thru’ mode.

MIDI YOKE™ MIDI Yoke™ is a set of software drivers that create
software MIDI ports. These ports can be used to ‘plug
together’ software MIDI applications. For example,
one application can output to a MIDI Yoke™ port and
a different application on the same computer can
receive input from that same MIDI Yoke™ port,
effectively connecting the output of the first
application to the input of the second.

MIRROR When linking Mix Icons, the link rules can be set to
determine how the linked Icon’s movements are
controlled. A common linking rule is a ‘mirror’
operation where one of the coordinates would be
inverted around the Mix Origin, creating a ‘mirror’
effect, as if the Mix Icon were reflected around the
Mix Origin.

MIX CONSOLE A Mix Console is a device that usually controls
multiple channels of audio inputs and outputs. The
audio on these inputs can have their volume and
filtering adjusted and effects added before being sent
to the outputs.
Mix Consoles are used by the audio engineer to create
final works of audio production such as records or
movies by manipulating the Mix Console controls to
achieve the desired effect.

MIX FORM A Mix Form is a window that has one or more Mix
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Icons placed on it to control some piece of audio
hardware or software.
A stereo Mix Form represents a half plane where the
Mix Form Coordinates can range from +/- X to only
+Y. A Surround Sound Mix Form represents a full
plane where the Mix Form Coordinates range from +/-
X and +/- Y. The maximum values of the coordinates
are 100% and the minimums are 0 at the Mix Form
Origin.

MIX FORM COORDINATE A Mix Form Coordinate is one of Radius, Theta, X,
and Y. These coordinates are converted into control
commands by the placement of a Mix Icon and the
individual VSL control settings.

MIX FORM ORIGIN The Mix Form Origin is where the Radius, X and Y
have a value of 0%. For a Stereo Mix Form, the Mix
Form Origin is at the bottom center, for a Surround
Mix Form, the Mix Form Origin is in the center.

MIX FRAME The Mix Frame is the outermost window of a
GraphiMix™ mix session.

MIX ICON A Mix Icon is a graphic object that is placed on a Mix
Form to represent and control a collection of controls
that affect the Mix Parameters for a single source of
sound. For example, a single Mix Icon may control
both the volume and the pan position mixer controls
for a single channel.

MIX ICON STATE The Mix Icon State is represented by its coordinates
on the Mix Form as well as the setting of any internal
states that it may have. A switch-type Mix Icon, for
example, has two additional states, Switch On and
Switch Off, in addition to the coordinates of its
position on the Mix Form.

MUTE BOUNDARY The Mute boundary is the circle that is at the 100%
Mix Form Radius coordinate. If a fader is attached to
the InverseRadius Mix Icon coordinate, then the value
of the attached fader will be 0 (muted) at this point. At
any point beyond this Mute Boundary, the fader will
remain muted. This area is the Mute Region.
For X/Y Mix Forms, the Mute Boundary is a square at
+/- 100% X and Y coordinates.
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MUTE REGION The Mute Region is the area that is beyond the Mute
Boundary, depending on the Mix Form type. If the
Inverse coordinate function is used, this area can be
used to ‘park’ inactive or muted Mix Icons.

NON-LINEAR A Non-Linear function is a function where the output
changes in an abrupt manner and does not follow a
straight line.

PANPOT A Panpot control usually takes an audio signal and
distributes it between two or more output channels.
The relative distribution between the output channels
can be changed by setting the pan position
appropriately. For example, if the stereo pan position
control is in the middle, the signal is evenly divided
between the two output channels. If it is turned toward
the right, then more signal is sent to the right output
then to the left output.

PANPOT CONVERGENCE The Panpot Convergence refers to exactly how the
signal is distributed to the output channels as the
control is centered. Normally, signal power is
conserved, and if the control is centered, each output’s
level is -3dB down from the input (total output power
= total input power). In some situations, the user may
desire that both channels get boosted or cut from this
value. This change is made by adjusting the Panpot
convergence up or down.

PAR FILE The Yamaha DME32™ can output a file that
describes its custom configuration of mixer controls
and effects. This PAR file can be imported by the
GraphiMix02™ to create a custom VSL file which can
be used in a GraphiMix™ mix session.

PC SOUND CARD A personal computer that features sound capability
(beyond keyboard beeps) contains a PC Sound card.
Most PC Sound cards can respond to MIDI commands
to create and modify sounds.

PIXEL A pixel is another name for a Picture Element, which
is a single, addressable ‘dot’ on a graphic display.

PROTOCOL A message Protocol is an instruction for how to
construct a message to be sent and received between
two communicating devices. MIDI and TCP/IP are
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two examples of message protocols.

PURCHASE NUMBER The Voyager Sound GraphiMix™ requires four fields
of information to enable all its features. The Purchase
Number is issued by Voyager Sound based on the
product and the date of purchase.

QUAD One of several different types of Surround Sound.
Quad usually involves 4 separate speakers and 4
separate channels of sound.

RADIUS The Radius represents the Mix Icon’s distance from
the Mix Origin.

RADIUS BOUNDARY The Radius boundary is where the Mix Form Radius
Coordinate becomes 100%.

REBOOT Some software installations may require the user to
shut down Windows (using the Start->Shut down
menu in the desktop’s lower left corner) and restart.
This is termed a ‘reboot’.

REGISTRATION FIELD The Voyager Sound GraphiMix™ requires four fields
of information to enable all its features. These fields
are called ‘Registration Fields’. These can be accessed
under the ‘Help’ menu.

RESPONSIVENESS GraphiMix™ can ‘smooth out’ the mouse movement
by effectively averaging many mouse move events and
outputting the time average instead of the current
mouse position. This has the effect of giving the Mix
Icon a ‘smoother’ feel when adjusting its position with
the mouse.

REVERB Reverb is a type of effect that adds ‘echo’ to the audio
signal. Depending on the amount and kind of echos
(reverb parameters) the effect can range from
simulating room acoustics to a setting that is an
intentional distortion to create a unique effect.

RS422 RS422 is a serial port hardware interface standard.
Message protocols may specify serial interface
standards such as RS232, RS422, or MIDI.

RUNTIME ‘Runtime’ refers to when engineer is using
GraphiMix™ to actually perform the audio mix. This
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is in contrast to when the engineer is designing the
mix session by creating Mix Icons and Mix Forms.

SCENE A GraphiMix™ scene contains one or more Mix
Session States.  Each state contains an entirely
separate copy of the Mix Session allowing for extreme
flexibility in defining Mix Session presets.

SOFTWARE METHOD A ‘Software Method’ defines a certain algorithm for
converting one kind of data value (such as a Mix Icon
Coordinate) to another (such as a control value).

SPLASH SCREEN The Splash Screen is the initial screen image that
comes up on the user’s monitor. The splash screen
contains the application manufacturers name and the
US and foreign patents that apply.

STATE A GraphiMix™ state contains an entirely separate
copy of a mix session. Each Mix Session State can
represent an entirely different arrangement for control
of the mix hardware.

STEREO A Stereo mix usually has at least two sets of output
channels, one labeled ‘Left’ and one ‘Right’.

SUB MIX A ‘Sub-Mix’ usually involves a subset of the available
inputs that are mixed together separately before
entered into the ‘Main Mix’. An example would be a
situation where a drum set might have several
microphones placed to optimally record the bass drum,
the cymbals, the high-hat, and the toms. These
separate inputs might be mixed together with a ‘drum
sub-mix’ before the single or stereo output of this sub-
mix is entered into the ‘main mix’ with the rest of the
channels representing all the other instruments in the
session.

SURROUND A ‘Surround’ mix involves output channels that
represent a 360 degree sound field when played. An
example would be a multi-channel movie mix where
sound effects can come from behind and even from
within the audience. This can range from as few as 3
to a large number of output channels. The
GraphiMix™ provides several types of Surround Mix
Forms.
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SWITCH A switch is a two state device consisting of an ON and
an OFF state. A multiple-pole switch is actually a
series of two state switches mechanically or
algorithmically linked together.

SYSEX MIDI SYStem EXclusive messages are abbreviated as
SYSEX and are a type of variable-length MIDI
message.

SYSTEM EXCLUSIVE MIDI System Exclusive messages are a message type
that begins with a <hexadecimal>F0 and ends with a
<hexadecimal>F7. This is the only MIDI message
type that is variable length. In practice, SYSEX
messages are used to signal everything from control
and program changes to bulk dumps and loads of the
entire hardware system state.

TAB BAR A Tab bar is a toolbar of tabs, each tab pulling up a
separate page, menu, or Mix System State.

TCP/IP This is a message protocol used over networks to
allow computers to access other computers and the
world wide web. It is an acronym that stands for
Transport Control Protocol-Internet Protocol.

TEMPLATE SESSION Creating a Mix Session from a blank Mix Form can be
somewhat tedious if a large number of controls are to
be created. To speed this process somewhat, Voyager
Sound Inc provides several ‘template’ Mix session
files already set up to interface to several popular
digital mix consoles via MIDI. These ‘template’
session files can be copied, modified, and customized
to any degree. Individual Mix Icons with controls
attached can be copied, cut, and pasted to other Mix
Forms.

THETA A Mix Form and Mix Icon Coordinate. Front center is
0 degrees. Negative angles are on the left and positive
angles are on the right. When converted to a Mix Icon
control value, MIN is at the left extreme and MAX is
at the right extreme.

TOKEN A token in the VSL Control language is an individual
value or identifier, in a stream of such identifiers, that
represents a value or a computation in the output
message protocol specified in the VSL entry for a
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particular control. For example, the MIDI channel
number, the address of the control in a control change
command, or the value sent to a mix console fader
control would all be represented as tokens in the VSL
file.

TOOL BAR A tool bar is a collection of icons that perform actions
within the GraphiMix™ application when clicked with
the mouse. A toolbar can be attached as a unit to the
Mix Frame or floated free as an independent window.

TOOL KIT GraphiMix™ includes a ‘kit’ of tools that help the
user construct and customize the Graphic User
Interface he uses to control the attached mixer
hardware.
The user can create his own Mix Icons and their
behaviors, decide how his hardware is to be controlled
by Mix Icon movement, and how many or how few
controls he wants on each Mix Form.
GraphiMix™ is really a toolkit of parts that can be
assembled in many unique and individual ways to suit
any engineer and any session requirements to create a
more effective way to control audio mix hardware.

TOP-DOWN A term that means from the most general description
progressing to the most detailed description.

UART An acronym that means Universal Asynchronous
Receiver Transmitter. A UART is a device that sends
and receives messages to external devices through a
variety of serial protocol interface standards.

VIRTUAL CONSOLE A Virtual Console is a representation of an audio mix
console on a computer screen.
A virtual console may appear as a graphic simulation
of a standard hardware console (a ‘Glass Console’) or
as a multi-dimensional Graphic User Interface (the
GraphiMix™).

VLB FILE The GraphiMix™ uses a file with the filename
extension ‘.VLB’ to hold each individual Mix Icon
Object and its image. Each Mix Icon that is shown in
the Mix Icon Selection Window and in the Mix Icon
Images properties tab is represented by a single VLB
file. An individual VLB may be used by more than
one Mix Icon at a time and on more than one Mix
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Form.

VOY FILE A GraphiMix™ session is stored in a file with the
filename extension ‘.VOY’.

VSL FILE The control recipes that detail the message protocol
for a particular piece of controllable hardware is
contained in a file with the filename extension ‘.VSL’.
An individual user may create VSL files with up to 32
controls each.  Larger VSL files are available from
Voyager Sound Inc.

WEECON A tiny (‘wee’) icon can be attached to the corner of a
Mix Icon to add extra distinguishing marks to allow
the user to visually discriminate the selected Mix
Icons.

WORK SURFACE The term ‘Work Surface’ refers to the placement and
arrangement of the collection of controls arrayed on a
screen or on the surface of a mix console. The design
of the ‘work surface’ can help or hinder the engineer’s
ability to create the audio work-in-progress.


